Performance Alert
Incident Report for Peach Payments
Resolved
Services have been fully restored. If you encounter any lingering issues, please reach out to support@peachpayments.com and provide the necessary details for further investigation. Thank you.
Posted Jul 19, 2024 - 13:34 SAST
Identified
We suspect that the issue is being caused by a wide scale vendor issue which has resulted in the servers being unavailable. The Teams are working to disable the impacted service to mitigate the issue.

We are actively working to restore services for affected customers. We have successfully reinstated several services and are making steady progress. We will provide an additional update as soon as full functionality has been re-established. Thank you
Posted Jul 19, 2024 - 11:41 SAST
Investigating
We are currently experiencing connectivity issues that are causing service disruption to some of our customers

Our Technical Teams are engaged and are working on priority to resolve this issue.

A further update will be shared within the next 1 hour or once the issue is resolved. Please reach out to support@peachpayments.com for any further queries.
Posted Jul 19, 2024 - 09:19 SAST
This incident affected: Peach card processing platform, Checkout, Support (Card portal (BIP)), and Third-party Platforms (Absa card acquiring, FNB card acquiring, I&M Bank Acquiring - Kenya, Issuing systems for Card processing, Nedbank card acquiring, Peach card acquiring, Planet Payments Multi Currency Payments, Standard Bank card acquiring, Tyme bank card).