Capitec App downtime
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 08:36 SAST
Investigating
The Capitec banking app and online banking platforms are experiencing technical issues.

The Capitec team are working on resolving this. Apologies for any inconveniences caused.

If you have any questions or concerns please reach out to support@peachpayments.com
Posted Mar 19, 2024 - 13:50 SAST
This incident affected: Peach card processing platform and Third-party Platforms (Capitec Pay).