Capitec App Push Notifications Issues

Incident Report for Peach Payments

Resolved

Please note that the issue with the Capitec App push notifications has been resolved. Capitec will continue to monitor.
Posted Apr 07, 2026 - 13:01 SAST

Investigating

Please note that Capitec are currently experiencing an issue with their Capitec App push notifications. The teams are working on the issue and we will update accordingly.

Date: Tuesday 7 April 2026
Time: From 10:30AM and ongoing
Impacted Applications: APP, Capitec Pay and Secure Data APIs
Posted Apr 07, 2026 - 11:56 SAST
This incident affected: Third-party Platforms (Capitec Pay).