Peach Dashboard - Transactions not appearing

Incident Report for Peach Payments

Resolved

Peach payments engineers successfully rolled back the changes and now, we can confirm that the transaction view is restored.

Thank you.
Posted Jul 31, 2024 - 19:01 SAST

Investigating

Following a deployment this evening, some merchants are not able to view their transactions on Dashboard.
Peach Engineering teams are currently rolling back the deployment.

Transaction processing is not affected.

For any further queries, please feel free to reach out to support@peachpayments.com. Thank you.
Posted Jul 31, 2024 - 18:56 SAST
This incident affected: Support (Dashboard - Peach Payments).