MauCAS degraded performance

Incident Report for Peach Payments

Resolved

This incident has been resolved!
Posted Jul 22, 2026 - 12:16 SAST

Monitoring

Successful transactions are being observed again for MauCAS as we continue to monitor.
Posted Jul 22, 2026 - 08:24 SAST

Update

We are continuing to investigate this issue.
Posted Jul 21, 2026 - 14:03 SAST

Investigating

We are currently experiencing degraded performance affecting MauCAS services. Our team has reached out to MauCAS to investigate further and work towards a resolution.

We apologise for any inconvenience this may cause and will continue to provide updates on this status page as more information becomes available.

If you have any questions or concerns, please contact support@peachpayments.com or reach out to your Account Manager.
Posted Jul 21, 2026 - 13:49 SAST
This incident affected: Checkout and Plugins and Platforms (Payment API).