1Voucher experiencing degraded performance

Incident Report for Peach Payments

Resolved

The issue has been resolved by the 1voucher team. Merchants' customer can now pay using 1voucher.

We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jun 04, 2025 - 12:13 SAST

Identified

The 1Voucher provider has confirmed that they are currently experiencing unexpected downtime across their products. Their team is actively working to resolve the issue.
Posted Jun 04, 2025 - 12:08 SAST

Investigating

1Voucher are currently experiencing an issue where transactions are intermittently failing. Our team has already reported the issue to 1Voucher provider and they are investigating and working to resolve it as soon as possible.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jun 04, 2025 - 11:21 SAST
This incident affected: Third-party Platforms (1Voucher).