VOIP Telephone system is unavailable

Incident Report for Peach Payments

Resolved

This incident has been resolved and you can now reach out to Peach on phones.

We apologise for the inconvenience caused. If you have any questions or concerns, please contact support@peachpayments.com or your account manager. Thank you.
Posted Sep 17, 2024 - 08:24 SAST

Investigating

VOIP Telephone system is unavailable.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Sep 16, 2024 - 09:03 SAST
This incident affected: Support (Phone Support).