Peach Payments intermittent declines

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Oct 02, 2025 - 13:50 SAST

Monitoring

A fix has been implemented and we are monitoring
Posted Oct 02, 2025 - 13:08 SAST

Investigating

We are currently seeing our checkout and payments API experiencing an outage. We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Oct 02, 2025 - 12:52 SAST
This incident affected: Peach card processing platform.