Nedbank Card Acquiring Downstream

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Feb 07, 2025 - 18:08 SAST

Monitoring

The issue has been resolved. Merchants' customer can now transact using Nedbank services.

We apologise for any inconvenience caused and thank you for your patience while the Nedbank Team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Feb 07, 2025 - 16:36 SAST

Update

Nedbank Card acquiring is currently experiencing degraded performance resulting in merchants' customers not being able to process card payments. Our team is investigating the issue and working to resolve it as soon as possible.
Posted Feb 07, 2025 - 16:00 SAST

Investigating

We are currently investigating the issue
Posted Feb 07, 2025 - 15:58 SAST
This incident affected: Peach card processing platform.