Intermittent degraded performance on card processing
Incident Report for Peach Payments
Resolved
The issue has been resolved and the system is operating as expected.

A RCA will follow.

We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jun 04, 2024 - 14:50 SAST
Update
Investigating — Tuesday, June 4, 2024 01:04 PM South Africa Standard Time

We apologise for the continued interruption to your service and would like to assure you that we are doing everything we can to restore services to normal without further delay. The issue, as mentioned earlier appears to lie with an issue upstream with a 3rd Party Tier 1 ISP, and our own ISP providers are working with the vendor to troubleshoot the issue.
The issue seems to primarily affect Mastercard traffic but we do also see a small percentage of affected VISA traffic. From a shopper perspective, 3DS verifications are the main cause of failures as the 3DS check does not get completed and times out. A high percentage of shoppers retry their 3DS check several times, eventually leading to success.
Posted Jun 04, 2024 - 13:23 SAST
Update
Investigating — Tuesday, June 4, 2024 12:10 PM South Africa Standard Time
Our downstream partner is continuing to work with their ISP providers to ascertain the latest update on this issue. The ISP providers have confirmed they are also receiving reports of issues for other customers of theirs and they are in contact with their own Tier 1 ISP provider.
Posted Jun 04, 2024 - 12:27 SAST
Update
Attempts have been made to move traffic to the alternate data center have not solved the issue. The issue is visible from both datacenters of our partner using different network providers. We have heard back from our ISP providers and they reported there is a suspected issue with Tier 1 ISP that is being utilized during the transaction flow. ISP providers are reaching out to gather further information on that issue and ascertain whether that could be the route cause of this issue.
Posted Jun 04, 2024 - 10:24 SAST
Update
Our downstream partner is awaiting insights from the ISP and the acquirer, our strategy involves a methodical assessment of impact and migration of the affected VPNs from the Primary environment to the alternate site. This move is aimed at evaluating the possibility of mitigating the impact through this transition
Posted Jun 04, 2024 - 09:03 SAST
Update
Our technical teams are actively working to resolve the issue, with engineers meticulously analyzing VPN logs to pinpoint the underlying cause. Concurrently, we are conducting a thorough internal review, and our ISP partners are also examining potential sources of the problem from their end
Posted Jun 04, 2024 - 08:11 SAST
Update
We are continuing to investigate this issue.
Posted Jun 04, 2024 - 06:38 SAST
Investigating
Our teams are mobilizing and initiating an investigation into the issue. We will provide additional information as soon as it becomes available. Thank you for your patience and understanding.

If you have any questions, please contact us via support@peachpayments.com or reach out to your account manager.
Posted Jun 04, 2024 - 06:01 SAST
This incident affected: Third-party Platforms (Absa card acquiring, FNB card acquiring, I&M Bank Acquiring - Kenya, Nedbank card acquiring, MCB Bank Mauritius, Peach card acquiring, Planet Payments Multi Currency Payments, Standard Bank card acquiring).