Sandbox: Intermittent Card Transaction Failures

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 05:25 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2026 - 15:43 SAST

Investigating

We are currently investigating an intermittent issue affecting card transactions in the Sandbox environment, where transactions may fail with an "unexpected communication error with connector/acquirer" response.

Our teams are actively working to identify the root cause and resolve the issue. Further updates will be shared on this page as soon as more information becomes available.

If you have any questions or require assistance, please contact support@peachpayments.com or reach out to your Account Manager.
Posted Aug 25, 2026 - 09:03 SAST
This incident affected: Peach card processing platform.