Instant EFT by Peach Payments intermittent performance
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 12:41 SAST
Update
We are continuing to investigate this issue.
Posted Jan 25, 2023 - 10:45 SAST
Investigating
Instant EFT by Peach Payments is unfortunately, experiencing some operational downtime. We are investigating the potential issue that may be causing any impact on our clients. We are working to identify the scope of impact and implement a solution as quickly as possible.
This incident affects: 🏭, 🏦 Capitec, 🏦 Standard Bank, 🏦 FNB, 🏦 Absa, and 🏦 Nedbank.
Posted Jan 25, 2023 - 10:42 SAST
This incident affected: Third-party Platforms (Instant EFT by Peach Payments).