HOSTED CHECKOUT UNAVAILABLE

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Feb 25, 2025 - 11:33 SAST

Investigating

We are currently experiencing an issue where merchants' customers cannot complete payments via payment links and Hosted Checkout. Our team is investigating the issue and working to resolve it as soon as possible.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Feb 25, 2025 - 11:29 SAST
This incident affected: Checkout.