Absa Cards intermitted performance

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Mar 03, 2023 - 14:39 SAST

Investigating

We are currently investigating this issue.
Posted Mar 03, 2023 - 10:23 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).