Nedbank acquiring
Incident Report for Peach Payments
Postmortem

We are still awaiting an RCA from Nedbank in this regard, will provide copy of same once received.

Posted Sep 28, 2023 - 08:44 SAST

Resolved
This incident has been resolved.
Posted Sep 21, 2023 - 00:50 SAST
Update
We are continuing to monitor for any further issues.
Posted Sep 20, 2023 - 23:49 SAST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 20, 2023 - 23:48 SAST
Update
Nedbank teams are currently in Triage and working on the issue. Peach engineers are providing support to the Nedbank teams to speed up identifying.
Posted Sep 20, 2023 - 20:31 SAST
Investigating
We are currently investigating this issue.
Posted Sep 20, 2023 - 19:09 SAST
This incident affected: Third-party Platforms (Nedbank card acquiring).