Planet Payment Transactions Failure
Incident Report for Peach Payments
Resolved
Planet payments services are now restored. The downtime lasted for 18 minutes and right now the services are online and fully functional.

Thank you.
Posted Oct 09, 2024 - 09:58 SAST
Investigating
Our monitoring system has detected a service defect of unavailability to PLANETPAYMENT. This is resulting in transaction failures that are being processed via Planet.

We have escalated to the provider and will provide updates. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Oct 09, 2024 - 09:46 SAST
This incident affected: Third-party Platforms (Planet Payments Multi Currency Payments).