Instant EFT by Peach Payments intermittent performance
Incident Report for Peach Payments
Resolved
This incident is now resolved and we apologise for any inconvenience this may have caused. All our systems are back online with all features back to being fully operational.
Posted Mar 06, 2023 - 18:33 SAST
Identified
Some users may experience slow response times or intermittent errors when making requests. Our engineering team is actively investigating the issue and working to resolve it as quickly as possible. We apologize for any inconvenience this may cause.
Posted Mar 06, 2023 - 16:08 SAST
This incident affected: Third-party Platforms (Instant EFT by Peach Payments).