Payouts and Debit Orders - CDV
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Feb 14, 2023 - 14:26 SAST
Investigating
Dear Peach Payments merchant

We would like to inform you that there have been some changes to the process of CDV. Previously, CDV was a built-in service, but it is now a standalone service that will be made available to you soon.

We are using a 3rd party for the CDV check and as recent as a few hours ago we have been made aware our ability to add the service has been removed. Our priority is to get the service added to your profile.
We are working with the 3rd party to have this resolved urgently.

We apologize for any inconvenience this may cause, and we will do our best to make the transition as smooth as possible. We will notify you as soon as the service is available for your use.

Thank you for your understanding and continued support.
Posted Feb 14, 2023 - 14:26 SAST
This incident affected: Third-party Platforms (Debit Orders, Payouts).