Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 07, 2026 - 00:01 SAST
Scheduled
FNB will be performing a network infrastructure change, FTD4PERIMETER Peering Layer Move (CHG0448435), on Sunday, 7 June 2026 from 00:00 to 01:00 SAST.
During the maintenance window, a traffic interruption of approximately 30 minutes is expected. FNB will actively monitor the environment throughout the maintenance window, and a rollback plan is in place should any issues arise.
Following the maintenance, all services will be validated to ensure connectivity has been fully restored.
If you experience any issues after the maintenance window or have any questions or concerns, please contact support@peachpayments.com or your Account Manager.
Posted Jun 05, 2026 - 14:58 SAST
This scheduled maintenance affected: Third-party Platforms (FNB card acquiring).