Capitec Pay payment issues

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 09:03 SAST

Investigating

Capitec Pay is currently experiencing payment issues. The team is investigating, and we will keep you updated as they progress.

We apologise for any inconvenience caused and will continue to update this status page as they make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Feb 19, 2025 - 08:34 SAST
This incident affected: Third-party Platforms (Capitec Pay).