Peach Payments Dashboard Login Issue

Incident Report for Peach Payments

Resolved

Please note that we have resolved an issue whereby users were unable to login to the Peach Payments Dashboard via the Magic Link.
Users were still able to make use of the username/password login.

Issue reported: 11:22 SAST

Issue resolved: 12:04 SAST

Should you have any queries in this regard, please email support@peachpayments.com, or contact your Account Manager.
Posted Apr 01, 2025 - 12:33 SAST
This incident affected: Support (Dashboard - Peach Payments).