EFT intermittent processing issue

Incident Report for Peach Payments

Resolved

The issue has been resolved. The service provider confirmed that the system is operating as expected.

We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted May 14, 2025 - 09:38 SAST

Update

We are continuing to investigate this issue.
Posted May 14, 2025 - 08:32 SAST

Investigating

We are currently experiencing an issue with EFT Processing. Our team has escalated it to our service provider and they are currently investigating.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted May 14, 2025 - 08:27 SAST
This incident affected: Third-party Platforms (Pay by bank EFT).