Capitec Pay - Capitec App degraded performance
Incident Report for Peach Payments
Resolved
CapitecPay
Good afternoon,
All services are back to normal. We'll keep monitoring closely.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Oct 01, 2023 - 18:23 SAST
Identified
Update: We are busy restarting Capitec Pay databases after which the issues should be resolved.
This restart might cause some downtime.
Posted Oct 01, 2023 - 17:41 SAST
Investigating
CapitecPay
Good afternoon,

We are seeing an increase in payment errors for Capitec Pay.
The team is looking into this and we'll provide feedback as soon as possible.

The impact is intermittent at this stage.
Priority 2 - High

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Oct 01, 2023 - 16:17 SAST
This incident affected: Third-party Platforms (Capitec Pay).