We are continuing to monitor for any further issues.
Posted Feb 16, 2025 - 11:40 SAST
Update
We are continuing to monitor for any further issues.
Posted Feb 16, 2025 - 08:03 SAST
Monitoring
Nedbank has confirmed a fix and that the system is now stable. We are monitoring the results.
Posted Feb 16, 2025 - 08:01 SAST
Update
Nedbank team is still investigating the issue. Transactions are affected intermittently over a period of few minutes.
Posted Feb 15, 2025 - 12:22 SAST
Investigating
Nedbank Team has advised that they are currently experiencing major network outage resulting in merchants' customers not being able to process card payments intermittently. Nedbank team is investigating the issue and working to resolve it as soon as possible.
We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Feb 15, 2025 - 10:32 SAST
This incident affected: Peach card processing platform and Third-party Platforms (Nedbank card acquiring).