Scan to Pay: intermittent downtime
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Apr 12, 2024 - 09:52 SAST
Investigating
Please note that the Scan to Pay payment method is currently experiencing connectivity issues, the team is currently busy working to resolve this issue.

Customer impact: Customers may not be able to transact on the Scan to pay Platform at this time.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Apr 11, 2024 - 11:56 SAST
This incident affected: Third-party Platforms (Scan to Pay (Masterpass)).