Mpesa transaction failures
Incident Report for Peach Payments
Update
We are continuing to investigate this issue.
Posted Jun 04, 2024 - 06:34 SAST
Investigating
Please note, we are currently seeing a spike in mpesa transaction failures.

Our team is investigating and we will provide updates as they become available.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted May 17, 2024 - 16:36 SAST
This incident affects: Third-party Platforms (MPESA).