Service degradation - Monitoring

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 21:57 SAST

Update

We are continuing to monitor for any further issues.
Posted Apr 02, 2025 - 21:21 SAST

Monitoring

We're seeing intermittent authorization failures for customers with ABSA merchant accounts on instore and e-commerce card payments.
Service is currently restored, and we will continue monitoring.


Please contact support - support@peachpayments.com or your KAM.
Posted Apr 02, 2025 - 21:18 SAST
This incident affected: In-store card processing (In-store card processing - Absa Card Present).