Microsoft downtime affecting card processing and 3DSecure
Incident Report for Peach Payments
Resolved
The residual impact of this event has been remedied by acquirers and processing has been restored to normal
Posted Mar 16, 2024 - 07:32 SAST
Update
We continue to monitor. We have seen recovery in most areas.
Posted Mar 14, 2024 - 20:16 SAST
Identified
Submarine cables Wacs and SAT3 are down. This is affecting multiple countries using these cable systems. Providers are trying to reroute as much traffic as possible but this is also causing congestion on the cables where traffic has been routed across.

Efforts to resolve are continuing. We will post any further updates here.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Mar 14, 2024 - 14:16 SAST
Investigating
Please note that due to a Global issue with Microsoft Azure since 1pm , we are seeing failures across multiple banks.

Currently, we have confirmed with FNB, ABSA, Nedbank, Standard Bank and Investec that this is affecting processing for them.

We are also seeing issues on Discovery - awaiting confirmation.

This is affecting both acquiring and issuing services.

FNB has advised that their systems are back up and we should start seeing an improvement there.

Please reach out to support@peachpayments.com with any questions or concerns.
Posted Mar 14, 2024 - 14:10 SAST
This incident affected: Peach card processing platform.