We are seeing Investec processing has resumed to normal.
We will continue to monitor.
We apologise for any inconvenience caused. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Nov 24, 2023 - 18:36 SAST
Update
We can confirm Nedbank addressed the 3D part of Nedbank transactions.
Investec - This is on the 3D part of the transaction and its held by the Customer bank who renders the 3D page and provides the 3D request to the user.
We apologise for any inconvenience caused. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Nov 24, 2023 - 14:59 SAST
Investigating
We have observed intermittent performance for Investec users and Nedbank users. Notifications have been sent to both banks to investigate. This is on the 3D part of the transaction and its held by the Customer bank who renders the 3D page and provides the 3D request to the user.
We apologise for any inconvenience caused. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Nov 24, 2023 - 11:49 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).