Dashboard Transaction Display Delay

Incident Report for Peach Payments

Resolved

The dashboard delay has been fixed, and all transactions are now updating normally.
Posted Sep 01, 2026 - 17:09 SAST

Monitoring

A fix has been implemented, and dashboard updates are stabilising. We are closely monitoring system performance and will provide further updates as needed.
Posted Sep 01, 2026 - 16:58 SAST

Investigating

We are currently experiencing a delay of up to 25 minutes in transactions appearing on the dashboard.

Please rest assured that transaction processing is fully operational and unaffected. Our engineering team is actively investigating the issue to restore real-time dashboard updates. We apologise for the inconvenience and will provide further updates here as we make progress.
Posted Sep 01, 2026 - 16:20 SAST
This incident affected: Support (Dashboard - Peach Payments).