Payment Links not being sent to SMS

Incident Report for Peach Payments

Update

Our investigation is still ongoing. SMS delivery remains intermittent and the issue is isolated to the Vodacom network. We continue to work with the provider and are actively monitoring the situation.

We apologise for any inconvenience caused and will continue to provide updates on this status page as more information becomes available.
Posted Jun 26, 2026 - 18:20 SAST

Identified

We are currently experiencing an issue where SMS messages are intermittently not being sent for Payment Links. Our team is investigating the issue with the provider and working to resolve it as soon as possible.

We apologise for any inconvenience caused and will continue to update this status page as we make progress.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jun 26, 2026 - 16:57 SAST
This incident affects: Plugins and Platforms (Payment Links).