FNB intermittent performance for cardholders
Incident Report for Peach Payments
Resolved
FNB has confirmed this has been resolved.
UPDATE: FNB - We apologise to customers for the limited functionality experienced on some of our services earlier today. We can confirm that this has now been resolved.
Posted Nov 04, 2022 - 18:24 SAST
Investigating
FNB has released a statement due to intermittent performance being experienced by FNB card holders:
FNB Bank
We sincerely apologise to customers for the limited functionality on our digital channels. Our IT teams are working to restore full functionality as soon as possible. We thank our valuable customers for your patience and ongoing support.
Posted Nov 04, 2022 - 15:12 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).