Dashboard - transaction details "tab" not available

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 17:21 SAST

Update

This incident has been resolved.
Posted Mar 24, 2026 - 17:21 SAST

Investigating

We are currently investigating an incident impacting the transactions details "tab" in dashboard.
Transactions are not affected, only the underlying detail is not being surfaced when clicking for additional information.
We will update as we continue to investigate.
Posted Mar 24, 2026 - 16:58 SAST
This incident affected: Support (Dashboard - Peach Payments).