Intermittent In-Store Card Processing Rejections

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 13:57 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 11, 2026 - 10:53 SAST

Investigating

We are currently experiencing intermittent rejections affecting in-store card processing, which may cause some transactions to fail unexpectedly.

Our team is actively investigating the issue and working to restore normal service as quickly as possible.

We apologize for any inconvenience caused and appreciate your patience while we work towards a resolution.

If you have any questions or concerns, please contact your Account Manager or email support@peachpayments.com.
Posted Jun 11, 2026 - 10:36 SAST
This incident affected: In-store card processing (In-store card processing - Absa Card Present, In-store card processing - Nedbank Card Present).