Peach Card processing Intermittent declines

Incident Report for Peach Payments

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 17, 2026 - 11:51 SAST

Investigating

We are currently experiencing intermittent transaction failures associated with error codes 900.100.300 and 900.100.203 on ABSA Acquiring. The teams are actively investigating the issue and will share updates as progress is made.

We apologise for any inconvenience this may cause and appreciate your patience while our team works to resolve the matter.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Feb 17, 2026 - 11:10 SAST
This incident affects: Peach card processing platform and Third-party Platforms (Absa card acquiring).