Capitec Degraded Performance

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 04, 2025 - 17:38 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 04, 2025 - 16:25 SAST

Investigating

Capitec is currently experiencing issues with their app, this is affecting both Cards and Capitec Pay. The team is investigating, and we will keep you updated as they progress.

We apologise for any inconvenience caused and will continue to update this status page as they make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 04, 2025 - 11:57 SAST
This incident affected: Third-party Platforms (Capitec Pay).