ABSA Service Disruption

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Aug 17, 2025 - 01:17 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2025 - 01:06 SAST

Investigating

We are currently seeing failures on ABSA, who are undergoing maintenance on their side. The ABSA team is on standby and monitoring the situation.

If you have any questions or concerns, please contact us at support@peachpayments.com or reach out to your account manager.
Posted Aug 17, 2025 - 00:42 SAST
This incident affected: Third-party Platforms (Absa card acquiring).