Standard Bank experiencing high volumes of rejections
Incident Report for Peach Payments
Resolved
This incident has been resolved.
Posted Oct 18, 2022 - 13:18 SAST
Investigating
Standard Bank Internet Banking and Business Online InaccessibleSubscribe
Update - Standard Bank: Business Online services are available following a fix. Customers are still unable to access Internet Banking. Please continue to direct customers to use Mobile Banking app, cellphone banking by dialling *120*2345# and ATMs as alternatives. We are working on resolving this urgently and apologise for the inconvenience caused.

Identified - Standard Bank: You may be unable to access Internet Banking and Business Online. Please use Mobile Banking app, cellphone banking by dialling *120*2345# and ATMs as alternatives. We are working on resolving this urgently and apologise for the inconvenience.
Posted Oct 18, 2022 - 11:56 SAST
This incident affected: Third-party Platforms (EFT Secure, Instant EFT by Peach Payments, Issuing systems for Card processing).