Checkout Webhooks

Incident Report for Peach Payments

Resolved

The issue has been resolved.

We apologise for any inconvenience caused and thank you for your patience while our team worked on the issue. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jul 23, 2025 - 14:27 SAST

Update

We are continuing to monitor for any further issues.
Posted Jul 22, 2025 - 14:29 SAST

Monitoring

We have fixed the issue. We are monitoring.

We had been experiencing an issue where transactions are being processed successfully, but the associated webhooks are failing to update to a success status. This was resulting in merchants receiving failed webhooks even though customers have been debited.
As a fix, we are manually setting the runtime version of affected to a previous working version. We are also investigating setting lambdas to manual updates to prevent similar issues in the future.


We apologise for any inconvenience caused. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jul 22, 2025 - 14:29 SAST

Investigating

Our Peach Payments Eng teams are investigating a webhook related issue.
Our teams are currently in a warroom.

We will provide further updates as the investigation progresses.

We apologise for any inconvenience caused. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Jul 22, 2025 - 14:12 SAST
This incident affected: Checkout.