VOIP Telephone system is currently unavailable

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 09:50 SAST

Investigating

VOIP Telephone system is currently unavailable. Kindly reach out to Peach support using support@peachpayments.com and our agents will assist further.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 11, 2025 - 08:52 SAST
This incident affected: Support (Phone Support).