Final Notice for 3DS2 Migration and Sunset 3DS 1 - Server-2-Server API Integration Merchants
Scheduled Maintenance Report for Peach Payments
Completed
The scheduled maintenance has been completed.
Posted Oct 14, 2022 - 19:00 SAST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 14, 2022 - 07:00 SAST
Scheduled
Good Day Peach Merchants,

At Peach Payments, we strive to continuously provide world-class, leading payments infrastructure that offers a secure and seamless experience for our merchants and their customers.

One of the major initiatives that we are currently undertaking (in line with global payment standards) is switching over our merchants to the VISA and Mastercard-mandated 3D Secure Version 2 authentication flow. To find out more about 3DS 2 and why switching to this standard will add considerable value to your business, please have a look at this support page we have put together for you: What is 3DSecure 2?

Be advised that the global sunset deadline for the 3DS2 switchover is the 14th of October 2022.

Following this date, all merchants still not configured for 3D Secure 2 will have their transactions fail. This is a limitation set out by the Schemes VISA and Mastercard.

If you have integrated Peach Payments with our Copy and Pay or MSDK API packages and Peach Payments Plugin (WooCommerce etc), then you can ignore this mailer - Peach will ensure you are enrolled for 3D Secure 2 by the time of the deadline.

IF you have a CustomWeb plugin which includes Wallee, please reach out to CustomWeb/Wallee directly to confirm their readiness status.

If you have integrated our Server-2-Server API, the following section applies to you, and it is imperative that the following has been actioned by the 12th of October 2022 at the latest:

If you are not sure of the integration you have implemented, please urgently reach out to your developer or the third party that you employed to integrate Peach Payments into your site:

One of the major initiatives that we are currently undertaking is switching over our merchants to the 3D Secure 2 standard, as part of a global roll-out.

After a technical assessment of your integration with Peach, we observed that extra technical work will be required on your side for this switchover to be completed (If not already completed). You will need to add a few extra parameters to your integration in order to handle 3DS Secure version 2 (Communications about these changes were likely sent out prior to you coming on board with us).

The changes that need to be made can be found on this link here: https://peachpayments.docs.oppwa.com/tutorials/threeDSecure/3d-secure-2.0-guide#Technicalintegrationguide-OPPServertoServer

From the above link:
Everything up until the section “Fields Required for 3D Secure 2” needs to be added.
Then, from the section “Fields Required for 3D Secure 2”, every parameter marked with “Mandatory”, needs to be included. The “Required unless market or regional mandate restricts sending this information” are recommended and we advise that they are included, but are not mandatory.
Section on “Merchant related fields configured in the gateway” and thereafter, you do not need to worry about - they are handled on our end.

Please ensure that you have completed the above before the 12th of October 2022 so that we can be sure you are ready for the migration before the 14th of October.

Thank You for using Peach Payments as a Payment Gateway. We look forward to continuing to scale with you!

Please do not hesitate to reach out to us if you have any questions on support@peachpayments.com

Kind Regards,

Peach Payments Support
Posted Oct 04, 2022 - 15:10 SAST
This scheduled maintenance affected: Third-party Platforms (Absa card acquiring, Nedbank card acquiring, Peach card acquiring, FNB card acquiring, Planet Payments Multi Currency Payments, I&M Bank Acquiring - Kenya, Equity Bank Kenya, MCB Bank Mauritius).