Service degradation (Checkout): Merchants with webhooks in backoff will see delayed response

Incident Report for Peach Payments

Resolved

We're increasing our throughput on our webhook retries.

We can confirm that webhooks will continue to filter through in priority order (repeatedly failing webhooks as a lower priority), expect slight delays in webhook retries as we work through the backlog.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 16, 2025 - 18:49 SAST

Investigating

Service degradation (Checkout):
Merchants with webhooks in backoff will see delayed response.

Current our Engineers are working to restore the service. Webhooks retries are delayed.

We apologise for any inconvenience caused and will continue to update this status page as we make progress. If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 16, 2025 - 18:40 SAST
This incident affected: Checkout.