Cloudflare outage - intermittent affect on services

Incident Report for Peach Payments

Resolved

The issue has been resolved and all services affected by Cloudflare outage has been restored.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Dec 05, 2025 - 13:30 SAST

Update

We are continuing to monitor for any further issues.
Posted Dec 05, 2025 - 12:08 SAST

Update

We are continuing to monitor for any further issues.
Posted Dec 05, 2025 - 11:42 SAST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 11:21 SAST

Update

We are continuing to investigate this issue.
Posted Dec 05, 2025 - 11:07 SAST

Investigating

Our platforms and services might experience intermittent downtime as a result of the global Cloudflare connectivity issue.
Please note that we are available on our support line, as we wait for the fix on cloudflare side.

Our Eng teams are actively working on this.

Please contact your KAM or send a email to our support@peachpayments.com
Posted Dec 05, 2025 - 11:06 SAST
This incident affected: Support (Console, Freshdesk Peach Payments Support email), Checkout, Plugins and Platforms (Shopify), and Third-party Platforms (Capitec Pay).