Capitec EFT intermittent performance
Incident Report for Peach Payments
Resolved
Capitec Bank systems are back online, and Stitch services linked to Capitec Bank are now operational. We are closely monitoring for further outages.
Posted Mar 07, 2023 - 16:40 SAST
Investigating
Capitec is experiencing delays on their systems related to the processing of transfers.

Confirmation that Capitec is aware of this issue can be seen here:
https://twitter.com/CapitecBankSA/status/1632715727324028930
Posted Mar 06, 2023 - 18:22 SAST
This incident affected: Third-party Platforms (Instant EFT by Peach Payments).