Discovery Bank no longer supported on Pay by Bank and Peach EFT

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Apr 07, 2025 - 10:36 SAST

Investigating

Peach Payments' Pay by Bank and Peach EFT payment options no longer support Discovery Bank. This change follows Discovery Bank’s decision to withdraw the functionality required to process EFT transactions.

If you have any questions or concerns, please contact support@peachpayments.com or your account manager.
Posted Apr 07, 2025 - 10:36 SAST
This incident affected: Third-party Platforms (Instant EFT by Peach Payments).