Standard Bank - intermittent performance

Incident Report for Peach Payments

Resolved

This incident has been resolved.
Posted Sep 21, 2023 - 13:59 SAST

Investigating

Standard Bank - intermittent performance - we are seeing intermittent performance of Standard bank customers.
We have reached out to Standard bank to notify.
Posted Sep 21, 2023 - 13:04 SAST
This incident affected: Third-party Platforms (Issuing systems for Card processing).